Back to overview
Downtime
Disruption at Edge Nodes
Oct 08 at 07:28pm HDT
Affected services
Node
Resolved
Oct 08 at 07:40pm HDT
Full resolution - All services restored and verified
Affected services
Created
Oct 08 at 07:28pm HDT
BrandSSL experienced a service disruption affecting a subset of custom domains. The incident was caused by a propagation bug on one of our edge servers, resulting in downtime for affected customer endpoints
Affected services